均线共振指标

市場通用指標用法、自設指標、程式交易、選股,操作心法、心態、基本面、經濟面等金融相關議題之討論。
探花2009
文章: 57
註冊時間: 2019-01-25, 22:11

Re: 均线共振指标

文章 探花2009 » 2019-01-29, 20:48

黄磊 寫:
2018-12-31, 15:24
RoseMainz学长您好!根据您提供的网页链接,认真的看了试了,通达信软件还是不能识别ALIGN這個函數,请指教

MA1:=MA(CLOSE,5);
MA2:MA(CLOSE,21),LINETHICK1;
MA3:=MA(CLOSE,10);
MA4:MA(CLOSE,65);
DRAWICON(MA1>REF(MA1,1) AND MA2>REF(MA2,1) AND MA3>REF(MA3,1) AND C>MA4 ,96,1);
DRAWICON(MA1<REF(MA1,1) AND MA2<REF(MA2,1) AND MA3<REF(MA3,1) AND C<MA4 ,96,2);
DRAWICON(MA1>REF(MA1,1) AND MA2>REF(MA2,1) AND MA3>REF(MA3,1) AND C>MA4 AND ((C-L)/(H-L))>0.618 AND (C/REF(C,1))>1.0236 ,H+0.2,23);

这是我编的通达信的顺线指标。表态K用十字标识,我不会标识最大和次大阳线,所以只能凑合看,需要用眼挑选。

有什么问题,咱们继续讨论。



小丑人
文章: 174
註冊時間: 2016-12-24, 20:06

Re: 均线共振指标

文章 小丑人 » 2019-04-05, 12:03

探花2009 寫:
2019-01-29, 20:48
黄磊 寫:
2018-12-31, 15:24
RoseMainz学长您好!根据您提供的网页链接,认真的看了试了,通达信软件还是不能识别ALIGN這個函數,请指教

MA1:=MA(CLOSE,5);
MA2:MA(CLOSE,21),LINETHICK1;
MA3:=MA(CLOSE,10);
MA4:MA(CLOSE,65);
DRAWICON(MA1>REF(MA1,1) AND MA2>REF(MA2,1) AND MA3>REF(MA3,1) AND C>MA4 ,96,1);
DRAWICON(MA1<REF(MA1,1) AND MA2<REF(MA2,1) AND MA3<REF(MA3,1) AND C<MA4 ,96,2);
DRAWICON(MA1>REF(MA1,1) AND MA2>REF(MA2,1) AND MA3>REF(MA3,1) AND C>MA4 AND ((C-L)/(H-L))>0.618 AND (C/REF(C,1))>1.0236 ,H+0.2,23);

这是我编的通达信的顺线指标。表态K用十字标识,我不会标识最大和次大阳线,所以只能凑合看,需要用眼挑选。

有什么问题,咱们继续讨论。
学长,这里应该怎么写,编译没问题,但是指标上提示非法参数
您沒有權限檢視這篇文章所附加的檔案。

探花2009
文章: 57
註冊時間: 2019-01-25, 22:11

Re: 均线共振指标

文章 探花2009 » 2019-04-05, 13:32

小丑人 寫:
2019-04-05, 12:03
探花2009 寫:
2019-01-29, 20:48
黄磊 寫:
2018-12-31, 15:24
RoseMainz学长您好!根据您提供的网页链接,认真的看了试了,通达信软件还是不能识别ALIGN這個函數,请指教

MA1:=MA(CLOSE,5);
MA2:MA(CLOSE,21),LINETHICK1;
MA3:=MA(CLOSE,10);
MA4:MA(CLOSE,65);
DRAWICON(MA1>REF(MA1,1) AND MA2>REF(MA2,1) AND MA3>REF(MA3,1) AND C>MA4 ,96,1);
DRAWICON(MA1<REF(MA1,1) AND MA2<REF(MA2,1) AND MA3<REF(MA3,1) AND C<MA4 ,96,2);
DRAWICON(MA1>REF(MA1,1) AND MA2>REF(MA2,1) AND MA3>REF(MA3,1) AND C>MA4 AND ((C-L)/(H-L))>0.618 AND (C/REF(C,1))>1.0236 ,H+0.2,23);

这是我编的通达信的顺线指标。表态K用十字标识,我不会标识最大和次大阳线,所以只能凑合看,需要用眼挑选。

有什么问题,咱们继续讨论。
学长,这里应该怎么写,编译没问题,但是指标上提示非法参数

这是大陆常用的通达信软件上用的,没有其他参数啊。
要不QQ2529241755说?

小丑人
文章: 174
註冊時間: 2016-12-24, 20:06

Re: 均线共振指标

文章 小丑人 » 2019-04-07, 09:23

探花2009 寫:
2019-04-05, 13:32
小丑人 寫:
2019-04-05, 12:03
探花2009 寫:
2019-01-29, 20:48



MA1:=MA(CLOSE,5);
MA2:MA(CLOSE,21),LINETHICK1;
MA3:=MA(CLOSE,10);
MA4:MA(CLOSE,65);
DRAWICON(MA1>REF(MA1,1) AND MA2>REF(MA2,1) AND MA3>REF(MA3,1) AND C>MA4 ,96,1);
DRAWICON(MA1<REF(MA1,1) AND MA2<REF(MA2,1) AND MA3<REF(MA3,1) AND C<MA4 ,96,2);
DRAWICON(MA1>REF(MA1,1) AND MA2>REF(MA2,1) AND MA3>REF(MA3,1) AND C>MA4 AND ((C-L)/(H-L))>0.618 AND (C/REF(C,1))>1.0236 ,H+0.2,23);

这是我编的通达信的顺线指标。表态K用十字标识,我不会标识最大和次大阳线,所以只能凑合看,需要用眼挑选。

有什么问题,咱们继续讨论。
学长,这里应该怎么写,编译没问题,但是指标上提示非法参数

这是大陆常用的通达信软件上用的,没有其他参数啊。
要不QQ2529241755说?
我加了

回覆文章