乖離通道指標公式編寫的問題

市場通用指標用法、自設指標、程式交易、選股,操作心法、心態、基本面、經濟面等金融相關議題之討論。
回覆文章
TONY
文章: 4
註冊時間: 2018-05-20, 16:52

乖離通道指標公式編寫的問題

文章 TONY » 2018-05-25, 09:08

大家幫忙看看下面這個公式編寫有沒有問題哦,為什麼放入軟件裡面顯示不出來呢?
中轨:MA(CLOSE,21),COLOR0080FF;
BIAS65:=(CLOSE-MA(CLOSE,65))/MA(CLOSE,65)*100;
BIAS130:=(CLOSE-MA(CLOSE,130))/MA(CLOSE,130)*100;
上轨:(BIAS65(MAX)/100+1)*MA(CLOSE,65),COLORFFFF00;
下轨:(BIAS65(MIN)/100+1)*MA(CLOSE,65),COLORFFFF00;
上极:(BIAS130(MAX)/100+1)*MA(CLOSE,130),colorblue;
下极:(BIAS130(MIN)/100+1)*MA(CLOSE,130),colorblue;



TONY
文章: 4
註冊時間: 2018-05-20, 16:52

Re: 乖離通道指標公式編寫的問題

文章 TONY » 2018-05-25, 09:33

這個是我根據主控 移動平均線書本裡面的乖離信道指標瞎編寫的公式,大家能幫我一下么。我公式編寫不會,所以看了點教程隨便編了一下·····求助大家咯

頭像
韋中
文章: 1614
註冊時間: 2016-12-10, 07:48

Re: 乖離通道指標公式編寫的問題

文章 韋中 » 2018-05-25, 09:56

MAX的定義:
MAX(A,B)返回A和B中的較大值,例如:MAX(CLOSE-OPEN,0)表示若收盤價大於開盤價返回它們的差值,否則返回0。
但用MAX這個語法比較不好撰寫,建議改成HHV
HHV的定義:
HHV(X,N),求N週期內X的最高值,N=0則從第一個有效值開始。例如:HHV(HIGH,30),表示求30日最高價。

TONY
文章: 4
註冊時間: 2018-05-20, 16:52

Re: 乖離通道指標公式編寫的問題

文章 TONY » 2018-05-25, 10:04

韋中 寫:
2018-05-25, 09:56
MAX的定義:
MAX(A,B)返回A和B中的較大值,例如:MAX(CLOSE-OPEN,0)表示若收盤價大於開盤價返回它們的差值,否則返回0。
但用MAX這個語法比較不好撰寫,建議改成HHV
HHV的定義:
HHV(X,N),求N週期內X的最高值,N=0則從第一個有效值開始。例如:HHV(HIGH,30),表示求30日最高價。
謝謝韋中老師的提示,看您的書收益良多。

mantou0601
文章: 1
註冊時間: 2017-11-01, 09:32

Re: 乖離通道指標公式編寫的問題

文章 mantou0601 » 2018-05-25, 11:04

感觉楼主的指标和老师书上写的不太一样啊。书上是选一条ma做为中轴参考,书中以21ma举例,后面的65,130,260是用来捉21ma乖离大小的区间。我是这么理解的,不知道对不对。
用的是通达信看盘,以前按书上的内容写的公式供参考。
BIAS21:=(CLOSE-MA(CLOSE,21))/MA(CLOSE,21)*100;

上1:(HHV(BIAS21,65)/100+1)*MA(CLOSE,21),COLORYELLOW;
上2:(HHV(BIAS21,130)/100+1)*MA(CLOSE,21),COLORBLUE;
上3:(HHV(BIAS21,260)/100+1)*MA(CLOSE,21),COLORRED;
中轴:MA(CLOSE,21),COLORWHITE,LINETHICK2;
下1:(LLV(BIAS21,65)/100+1)*MA(CLOSE,21),COLORYELLOW;
下2:(LLV(BIAS21,130)/100+1)*MA(CLOSE,21),COLORGREEN;
下3:(LLV(BIAS21,260)/100+1)*MA(CLOSE,21),COLORRED;

不过看盘的时候,我还是更习惯看简单的52165ma。

TONY
文章: 4
註冊時間: 2018-05-20, 16:52

Re: 乖離通道指標公式編寫的問題

文章 TONY » 2018-05-25, 13:09

mantou0601 寫:
2018-05-25, 11:04
感觉楼主的指标和老师书上写的不太一样啊。书上是选一条ma做为中轴参考,书中以21ma举例,后面的65,130,260是用来捉21ma乖离大小的区间。我是这么理解的,不知道对不对。
用的是通达信看盘,以前按书上的内容写的公式供参考。
BIAS21:=(CLOSE-MA(CLOSE,21))/MA(CLOSE,21)*100;

上1:(HHV(BIAS21,65)/100+1)*MA(CLOSE,21),COLORYELLOW;
上2:(HHV(BIAS21,130)/100+1)*MA(CLOSE,21),COLORBLUE;
上3:(HHV(BIAS21,260)/100+1)*MA(CLOSE,21),COLORRED;
中轴:MA(CLOSE,21),COLORWHITE,LINETHICK2;
下1:(LLV(BIAS21,65)/100+1)*MA(CLOSE,21),COLORYELLOW;
下2:(LLV(BIAS21,130)/100+1)*MA(CLOSE,21),COLORGREEN;
下3:(LLV(BIAS21,260)/100+1)*MA(CLOSE,21),COLORRED;

不过看盘的时候,我还是更习惯看简单的52165ma。
朋友你好,我对于这个公式编写是属于完全陌生。只是最近在看老师的书,又因网络上没有现成的指标公式所以就自己按照网上的公式编写教材,再根据老师在书里对于指标的说明蛮编下看看行不行,本来想根据这个公式在反复去复盘去了解它,没有想到写了错误的公式,让大家见笑了。

回覆文章